Smart Community locations only. For Residential or Business Support Find options here
close button

Smart Communities
Status Site

65 Mary St, Brisbane City QLD 4000 - Ongoing Electrical Maintenance

Resolved
Operational
Started 11 days ago Lasted 1 day

Affected

Managed Wi-Fi
Australia & New Zealand
QLD Managed Wi-Fi
Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    Electricians are currently on-site performing maintenance to power in the building.

    Services will be interrupted while this occurs.